Skip To Content Skip To Navigation

Be prepared for the GPS Week Number Rollover

 

As you may have heard, there is a GPS Week Number Rollover taking place on April 6, 2019.  There are many questions and concerns surrounding this.  Below is a statement from Trimble regarding this event.
 
 -- 
 
“A GPS week rollover will occur at the end of the GPS day on 6 April 2019, at which time the GPS week will transition from week 2047 to 2048. However, because the GPS message structure broadcast by the satellites defines the week as a 10-bit value, the GPS messages will indicate that the week has changed from 1023 to week 0.
 
Trimble has performed tests using a GNSS simulator to verify that the receiver firmware correctly handles the week rollover in different scenarios, including real time kinematic and static surveys with various input and output messages, as well as data file format conversions.
 
To prepare for the week number rollover, it is recommended to install the latest receiver firmware version using Trimble Installation Manager for current products or Trimble WinFlash for legacy products. All Trimble receivers with firmware version ≥2.32 will continue to operate normally following the rollover.”
 
 --   
 
How Will This Affect Users?
 
Trimble Survey Users
 
If you have relatively current Trimble GNSS receivers with firmware greater than or equal to version 2.32, Trimble’s tests indicate they will continue to perform as usual.  Should you need peace of mind, you can choose to upgrade your receiver firmware to the recommended version. 
 
Links to specific bulletins for Trimble Survey and Trimble GIS GNSS products can be found here.  Below are the minimum and recommended firmware versions for all Trimble Survey and GIS receivers.
 

GPS and GNSS Hardware Supported Firmware Versions - Minimum Supported Firmware Versions - Recommended
Trimble 5700 Model 1 2.32 2.32
Trimble 5700 Model 2 All Versions Supported 4.90
Trimble 5800 Model 1 2.32 2.32
Trimble 5800 Model 2 All Versions Supported 4.43
Trimble R2 All Versions Supported 5.40
Trimble R4 Model 2 and Model 3 All Versions Supported 5.40
Trimble R4 Model 2 All Versions Supported 5.40
Trimble R4 Model 1 All Versions Supported 4.64
Trimble R5 All Versions Supported 5.00
Trimble R6 Model 3 and Model 4 All Versions Supported 5.40
Trimble R6 Model 2 All Versions Supported 4.64
Trimble R6 Model 1 All Versions Supported 4.64
Trimble R7 GNSS All Versions Supported 5.0
Trimble R8 Model 3 and Model 4 All Versions Supported 5.40
Trimble R8 Model 2 All Versions Supported 4.64
Trimble R8 Model 1 2.32 2.32
Trimble R8s All Versions Supported 5.40
Trimble R9s All Versions Supported 5.40
Trimble R10 + Trimble R10 LT All Versions Supported 5.40
Trimble R10 Model 2 All Versions Supported 5.40
Trimble NetR9 Geospatial All Versions Supported 5.40

 

GPS and GNSS Enabled Device Supported Firmware Versions - Minimum Supported Firmware Versions - Recommended
GeoExplorer 2008 & 3000 series GNSS firmware v2.11 GNSS firmware v2.11 or later
GeoExplorer 6000 series All Versions Supported GNSS firmware v3.06.1 or later
Geo 5T handheld GNSS firmware v1.05.1 GNSS firmware v1.05.1 or later
Geo 7X handheld All Versions Supported GNSS firmware v4.50.3 or later
GPS Pathfinder Pro 6T/6H receiver All Versions Supported System firmware v1.03 (GNSS v3.15)
GPS Pathfinder ProXT/XH receivers GNSS firmware v2.07 GNSS firmware v2.07 or later
GPS Pathfinder ProXRT receiver All Versions Supported GNSS firmware v4.44 or later
Juno S series All Versions Supported OS firmware v5.0.2 or later
Juno 3 series All Versions Supported OS firmware v1.03.1 or later
Juno 5 series All Versions Supported OS firmware v1.0.8 or later
Nomad 900 series All Versions Supported OS 1.2.2.0 or later
Nomad 1050 series All Versions Supported OS 2.0 or later
Nomad 5 handheld All Versions Supported OS Build 2011005-0209 or later
Yuma rugged tablet computer All Versions Supported OS R0.7 or later
Yuma 2 rugged tablet computer All Versions Supported OS 1.0.0.14 or later
R2 GNSS receiver All Versions Supported GNSS firmware v5.40 or later
R1 GNSS receiver All Versions Supported GNSS firmware 5.09 or later
T10 tablet All Versions Supported All Versions Supported
EM100 Empower module All Versions Supported GNSS firmware 5.32 or later
TDC100 series All Versions Supported All Versions Supported
TDC150 handheld Version 3.67 Version 3.67 or later
Trimble Catalyst Catalyst Service v1.1.2197 Catalyst Service v1.1.2197 or later

 

 

Trimble Business Center Users
 
For users running TBC version 4.10 and higher, there is a patch available. Run the Check for Updates command in the software to install. For users not eligible for v4.10 due to software warranty expiration, please contact Cansel Support for assistance.
 
 
 
Spectra Geospatial Survey and GIS GNSS Users
 
Spectra has issued new minimum firmware versions for many of their products, specifically to prepare for the GPS week rollover.  You must install the minimum firmware version corresponding to your receiver before April 6, 2019.  SP60 and SP80 receivers with expired firmware warranty can be upgraded at no cost.
 
Spectra would like to reiterate, “This is an urgent required action and receivers will not function correctly without the correct firmware.”
 
The bulletin for Spectra Geospatial products including minimum and recommended firmware versions and links to download them can be found here.
 
Below are the minimum and recommended firmware versions for all Spectra Geospatial receivers.

 

Device Type Supported Firmware Versions - Minimum Supported Firmware Versions - Recommended
SP90m V3.68 V3.68
SP80 V3.68 (for expired SP80 firmware maintenance - SP Loader V8.8) V3.68 (for expired SP80 firmware maintenance - SP Loader V8.8)
SP60 V3.68 (for expired SP60 firmware maintenance - SP Loader V8.8) V.381
SP20 V3.67 V3.67
MobileMapper50 Not impacted by GPS Week Number Rollover Not impacted by GPS Week Number Rollover
ProMark 800 v1.9.S815Kn27 v1.9.S815Kn27
ProFlex 800 v2.06.S850Kn27 v2.06.S850Kn27
ProMark 700 V4.70 V5.00
ProMark 100/200 V2.5.aW215Hm27 V2.5.aW215Hm27
ProMark 120/220 V2.5.aW215Hm27 V2.5.aW215Hm27
MobileMapper 100/120 V2.5.aW215Hm27 V2.5.aW215Hm27
MobileMapper 300 V4.70 V5.00
EPOCH 50 V4.00 V5.10
EPOCH 35 V3.62 V3.62
EPOCH 25 V2.32 V2.32
EPOCH 10 V1.00 V1.00
ProMark 500 V6.8.S814G126 V6.8.S814G126
ProFlex 500 V4.5.S767G224 V4.5.S767G224
ProMark 3 Not impacted by GPS Week Number Rollover Not impacted by GPS Week Number Rollover
MobileMapper 10 Not impacted by GPS Week Number Rollover Not impacted by GPS Week Number Rollover
MobileMapper6 Not impacted by GPS Week Number Rollover Not impacted by GPS Week Number Rollover

 

 

Spectra Precision Survey Office Users
 
For users running SPSO version 4.10 and higher, there is a patch available. Run the Check for Updates command in the software to install. For users not eligible for v4.10, more information is to follow.
 
 
 
Legacy Ashtech GNSS Users
 
For those operating legacy Spectra receivers such as the HDS800 and MB500, you can find firmware updates to address the GPS week rollover here.
 
 

 
For more information or any questions you may have, please contact support here or via 1-800-357-0561.